Releases

74 (v. 1040)

18-09-2020

Highlights

  • ATF updated to the final 2.3 release
  • Aktualizr-Lite updated to the revision 56f8357 (better app management and config reporting)
  • Container pre-loading removed from meta-lmp, now done via Factory CI
  • Curl updated to the 7.72.0 release
  • GCC updated to the 10.2.0 stable release
  • Glibc updated to the 2.32 release
  • Go updated to the 1.14.7 stable release
  • LSHW updated to revision 71cf63b
  • Libseccomp updated to the 2.5.0 release
  • Linux-firmware updated to the 20200817 snapshot
  • Linux-lmp updated to the v5.8.8 stable release
  • Linux-lmp-fslc-imx updated to v5.4.64 (based on NXP BSP 5.4.24 2.1.0)
  • Linux-lmp-lts updated to the v5.4.64 stable release
  • Meta-ARM (yocto upstream) was added to the default list of layers
  • Meta-toradex-nxp and meta-toradex-bsp-common layers were removed from LMP (due conflicts with other BSP layers)
  • Mfgtools enabled for apalis-imx6, apalis-imx8 and imx7ulpea-ucom
  • NXP BSP updated to the 5.4.24 2.1.0 release
  • New board support: imx7ulpea-ucom (from Embedded Artists)
  • Openvino updated to the 2020.4 release
  • Ostree updated to the 2020.5 release
  • Qemu updated to the 5.1.0 release
  • SQlite3 updated to the 3.33.0 release
  • Sudo updated to the 1.9.2 release
  • Signed and restricted boot support enabled for apalis-imx6, imx7ulpea-ucom and imx8mmevk.
  • Support for OPTEE-OS 3.10.0 and U-Boot 2020.04 (NXP BSP 5.4.24 2.1.0 based) added to meta-lmp (not yet enabled as default)
  • Support for the Toradex Linux BSP now provided by the linux-lmp-toradex-imx recipe
  • Systemd updated to the v246.2 release
  • Wireguard module updated to the 1.0.20200729 release
  • Wireguard tools updated to the 1.0.20200827 release

Layer Updates

Meta LMP

  • base: aktualizr-lite: bump to 56f8357
  • base: atf: bump to 2.3 final
  • base/bsp: optee-os-fio: migrate bsp from base to meta-lmp-bsp
  • base/bsp: optee-os: rename fio forked recipe to optee-os-fio
  • base/bsp: optee: update from 3.9.0 to 3.10.0
  • base/bsp: u-boot-fio-imx: drop recipe
  • base/bsp: version u-boot-fio-mfgtool
  • base: docker-ce: Remove service for container preloading
  • base: import image-license-checker.bbclass from arm mbed os
  • base: libseccomp: drop local changes
  • base: linux-lmp-lts: add recipe based on current linux-lmp (5.4.y)
  • base: linux-lmp-lts: update to v5.4.64
  • base: linux-lmp: update to v5.8.8
  • base: lmp: drop meta-toradex bbmasks
  • base: lmp: mask kernel recipes from meta-arm-bsp
  • base: lmp: mask optee recipes from meta-arm
  • base: lmp-update-hostname: use lowercase when fetching serial
  • base: lmp-update-hostname: use sys serial number if available
  • base: lshw: bump to 71cf63b
  • base: lxc: drop local changes
  • base: mfgtool-files: fix no packagedata warning
  • base: networkmanager: drop local changes
  • base: optee: client/examples/test: introduce version 3.9.0
  • base: optee: examples/sks/test: depend on python3-pycryptodomex-native
  • base: optee: fiovb/test/examples/sks: set libgcc locate cflags
  • base: optee: move git recipes version to 3.6.0
  • base: optee-os-fio: add version 3.9.0+git
  • base: optee-os-fio: bump to 7f17561e
  • base: optee-os-fio-mfgtool: add 3.9.0+git version
  • base: trusted-firmware-a: depend on optee based on machine features
  • base: u-boot-fio: add version 2020.04
  • base: u-boot-fio-imx: add version 2020.04
  • base: u-boot-fio-mfgtool: add version 2020.04
  • base: u-boot-fio: move common logic to u-boot-fio-common.inc
  • base: u-boot-fio: move git to 2019.10
  • base: wireguard-module: set rprovides if kernel != linux-lmp
  • base: wireguard-module: upgrade 1.0.20200712 -> 1.0.20200729
  • base: wireguard-tools: rdepend on kernel-module-wireguard
  • base: wireguard-tools: upgrade 1.0.20200513 -> 1.0.20200827
  • bsp: base-files: add fstab for imx7ulpea-ucom
  • bsp: base-files: apalis-imx6: add fstab
  • bsp: conf: add apalis-imx8 machine configuration
  • bsp: conf: add imx7ulpea-ucom machine configuration
  • bsp: imx-atf: apalis-imx8: bring changes from meta-toradex-nxp
  • bsp: imx-mkimage: drop changes
  • bsp: imx-mkimage: drop toradex/apalis-imx8 changes
  • bsp: imx-sc-firmware: add toradex changes
  • bsp: linux-lmp-dev: apalis-imx8: fix build with latest oe-core
  • bsp: linux-lmp-dev-mfgtool: add defconfig for imx7ulpea-ucom
  • bsp: linux-lmp-dev-mfgtool: apalis-imx6: add config
  • bsp: linux-lmp-ea-imx: add recipe
  • bsp: linux-lmp-fslc-imx: add optee/i2c patch
  • bsp: linux-lmp-fslc-imx: add recipe based on fslc imx 5.4.y
  • bsp: linux-lmp-fslc-imx: backport optee/hwrng patches
  • bsp: linux-lmp-fslc-imx: update to v5.4.64
  • bsp: linux-lmp-fslc-imx: upgrade to rel_imx_5.4.24_2.1.0 from NXP
  • bsp: linux-lmp-toradex-imx: add recipe based on toradex imx 5.4.y
  • bsp: linux-lmp-toradex-imx: bump rev to a110e42bea89f
  • bsp: lmp-machine-custom: add support for imx7ulpea-ucom
  • bsp: lmp-machine-custom: apalis-imx6: allow u-boot to be overwritten
  • bsp: lmp-machine-custom: apalis-imx6: enable sota ubootenv
  • bsp: lmp-machine-custom: apalis-imx6: enable uboot sign
  • bsp: lmp-machine-custom: apalis-imx6: switch to optee 3.10.0
  • bsp: lmp-machine-custom: apalis-imx6: switch to spl/optee/u-boot
  • bsp: lmp-machine-custom: apalis-imx8: update to latest BSP
  • bsp: lmp-machine-custom: beagle: switch to u-boot-fio 2020.04
  • bsp: lmp-machine-custom: colibri-imx7-emmc: switch to u-boot-fio 2020.04
  • bsp: lmp-machine-custom: cubox-i: switch to u-boot-fio 2020.04
  • bsp: lmp-machine-custom: drop preferred version settings for optee-os
  • bsp: lmp-machine-custom: imx7ulpea-ucom: enable u-boot sign
  • bsp: lmp-machine-custom: imx8mmevk: switch to latest u-boot-fio/optee-os-fio
  • bsp: lmp-machine-custom: mx6ull: move ostree kernel args to common
  • bsp: lmp-machine-custom: mx6ull/mx8mm: switch to linux-lmp-fslc-imx
  • bsp: lmp-machine-custom: mx6ull: switch to optee 3.10.0
  • bsp: lmp-machine-custom: mx8mm: enable uboot sign
  • bsp: lmp-machine-custom: qemuarm64: switch from atf to trusted-firmware-a
  • bsp: lmp-machine-custom: qemuarm64: switch to optee 3.10.0
  • bsp: lmp-machine-custom: qemuarm: drop UBOOT_MACHINE
  • bsp: lmp-machine-custom: qemu: switch to u-boot-fio 2020.04
  • bsp: lmp-machine-custom: remove OPTEE_WKS_FILE_DEPENDS on imx
  • bsp: lmp-machine-custom: rpi: switch to u-boot-fio 2020.04
  • bsp: lmp-machine-custom: set preferred u-boot-fio version for apalis-imx6
  • bsp: lmp-mfgtool-machine-custom: add support for apalis-imx8
  • bsp: lmp-mfgtool-machine-custom: add support for imx7ulpea-ucom
  • bsp: lmp-mfgtool-machine-custom: apalis-imx6: add config
  • bsp: lmp-mfgtool-machine-custom: mx6ull: use bsp tree for kernel
  • bsp: lmp-mfgtool-machine-custom: set kernel to fitimage
  • bsp: mfgtool-files: add files for apalis-imx6
  • bsp: mfgtool-files: add files for apalis-imx8
  • bsp: mfgtool-files: add support for imx7ulpea-ucom
  • bsp: mfgtool-files: imx8mmevk: use lmp-factory-image
  • bsp: mx6ull switch to u-boot-fio 2020.04 and signed u-boot
  • bsp: optee-os-fio: 3.10.0: add support for imx6ullevk
  • bsp: optee-os-fio: 3.10: add support for apalis-imx6
  • bsp: optee-os-fio: 3.10: add support for imx8mmevk
  • bsp: optee-os-fio-3.9.0: add config settings for qemuarm64
  • bsp: optee-os-fio: add support for imx7ulpea-ucom
  • bsp: optee-os-fio: imx8mmevk: 3.10.0: enable caam and rng pta
  • bsp: optee-os-fio: make bbappends specific to 3.6.0
  • bsp: optee-os-fio-mfgtool: add support for imx7ulpea-ucom
  • bsp: optee-os-fio-mfgtool: apalis-imx6: add support
  • bsp: optee-os-fio: update apalis-imx6 config settings
  • bsp: u-boot-base-scr: drop changes
  • bsp: u-boot: drop local changes
  • bsp: u-boot-fio: 2020.04: bump to b9c97cb72f1
  • bsp: u-boot-fio: add support for imx7ulpea-ucom
  • bsp: u-boot-fio: apalis-imx6: add config fragment
  • bsp: u-boot-fio: apalis-imx6: add fw_env
  • bsp: u-boot-fio: apalis-imx8: add initial config fragment
  • bsp: u-boot-fio: beagle: disable android boot image
  • bsp: u-boot-fio: colibri-imx7-emmc: set video link to y
  • bsp: u-boot-fio: cubox-i: disable ldo bypass check
  • bsp: u-boot-fio: imx7ulpea-ucom: add fw_env config
  • bsp: u-boot-fio: imx8mmevk: add fw_env config
  • bsp: u-boot-fio: imx8mmevk: enable config net again
  • bsp: u-boot-fio: imx8mmevk: enable fit signature strict
  • bsp: u-boot-fio-imx: allow recipe to use configs from u-boot-fio
  • bsp: u-boot-fio-mfgtool: add config for imx7ulpea-ucom
  • bsp: u-boot-fio/mfgtool: add support for imx8mmevk
  • bsp: u-boot-fio-mfgtool: apalis-imx6: add config fragment
  • bsp: u-boot-fio: mx8m: enable support for u-boot sign
  • bsp: u-boot-imx: drop local append logic
  • bsp: u-boot-ostree-scr: drop changes
  • bsp: u-boot-ostree-scr-fit: add boot.cmd for apalis-imx6
  • bsp: u-boot-ostree-scr-fit: add support for apalis-imx8
  • bsp: u-boot-ostree-scr-fit: add support for imx7ulpea-ucom
  • bsp: u-boot-ostree-scr-fit: add support for imx8mmevk
  • bsp: u-boot-script-toradex: drop recipe

Meta Freescale

  • asound.state: add support for wm8960 codec
  • cryptodev-qoriq: Upgrade to 1.11
  • firmware-imx: upgrade to version 8.8
  • firmware-qca: upgrade to 3.0.2
  • fsl-eula-unpack: exclude FSL_EULA_FILE from sstate signature
  • gstreamer1.0: update to NXP release MM_04.05.05_2005_L5.4.24
  • imx8: Drop unused IMAGE_BOOTLOADER
  • imx-atf: fix build with -fno-common
  • imx-atf: upgrade to 2.2
  • imx-base.inc: Change default Linux kernel to linux-fslc-imx
  • imx-codec: update to 4.5.5
  • imx-dpu-g2d: upgrade to 1.8.7
  • imx-gpu-apitrace: fix the upgrade after rebase to 9.0.0
  • imx-gpu-g2d: upgrade to 6.4.0.p2.4
  • imx-mkimage: upgrade to version 1.0
  • imx-parser: upgrade to 4.5.5
  • imx-sc-firmware: upgrade to 1.5.0 from NXP
  • imx-seco: upgrade to version 3.6.3
  • imx-uuc: bump up revision from upstream
  • imx-vpu-hantro: fix compilation issues with -fcommon
  • imx-vpu-hantro: upgrade to 1.18.0
  • imx-vpu: upgrade to version 5.4.39.3
  • imx-vpuwrap: upgrade to 4.5.5
  • kernel-module-imx-gpu-viv+fslc: Update to version 6.4.0.p2.4-based
  • kernel-module-imx-gpu-viv: upgrade to 6.4.0.p2.4
  • kernel-module-qca9377: update recipe name to 3.1
  • linux-fslc-imx: add mx8mn uuid patches from linux-5.8.y
  • linux-fslc-imx: update to v5.4.62 + fix soc uuid read
  • linux-fslc-imx: upgrade to rel_imx_5.4.24_2.1.0 from NXP
  • linux-fslc: upgrade kernel to v5.4.62 from korg
  • linux-imx-headers: upgrade to rel_imx_5.4.24_2.1.0
  • linux-imx[-mfgtool]: Upgrade kernel recipe to 5.4.24-2.1.0 from NXP
  • optee-imx: upgrade to version 3.7.0
  • SCR-5.4.24_2.1.0.txt: Update SCR for latest NXP release
  • SCR-5.4.3_2.0.0.txt: Update SCR for latest NXP release
  • u-boot-imx: upgrade to imx_v2020.04_5.4.24_2.1.0
  • Update linux-fslc-qoriq to v5.4.58

Meta Intel

  • gmmlib: upgrade 20.2.2 -> 20.2.5
  • intel-mediasdk: upgrade 20.2.0 -> 20.2.1
  • libipt: upgrade 2.0.2 -> 2.0.3
  • linux-intel/5.4: update to v5.4.57
  • linux-intel: backport commit to fix perf builds
  • linux-intel-rt/5.4: update to v5.4.52
  • open-model-zoo: upgrade 2020.3 -> 2020.4
  • openvino-inference-engine: upgrade 2020.3 -> 2020.4
  • openvino-model-optimizer: upgrade 2020.3 -> 2020.4
  • slimboot-tools: add support for slimbootloader tools

Meta OpenEmbedded

  • abseil-cpp: Use SkipRecipe exception
  • Adding recipe for exprtk
  • aoetool: make builds reproducible
  • apache2: upgrade v2.4.43 -> v2.4.46
  • apache-websocket: upgrade 0.1.1 -> 0.1.2
  • asio: extend recipe to add native support
  • autossh: Created recipe
  • bearssl: add new recipe
  • bearssl: fix missing install
  • boost-url: Add recipe
  • broadcom-bt-firmware: add PE back
  • broadcom-bt-firmware: update to 12.0.1.1105_p2
  • capnproto: upgrade 0.7.0 -> 0.8.0
  • c-ares: upgrade 1.16.0 -> 1.16.1
  • cdrkit: Fix build with -fno-common
  • cli11: 1.9.0 -> 1.9.1
  • crash: Fix arm64 build with -fno-common
  • crossguid: update to 0.2.2
  • daq: Upgrade to 2.0.7
  • dash: upgrade 0.5.11 -> 0.5.11.1
  • dctl: update v69
  • dhcpcd: update to 9.1.4
  • dialog: Turn X11 support into a packageconfig option
  • dialog: update to 1.3-20200327
  • dibbler: Update to latest
  • directfb: Disable dtor-typedef warning with clang11
  • dlt-daemon: add new dlt-filetransfer PACKAGECONFIG option
  • dlt-daemon: enable some configurations by default in PACKAGECONFIG
  • dlt-daemon: fix build failure when dlt-dbus is enabled, due to missing service file.
  • dlt-daemon: fix build with upstream-proposed patch for MUSL libc
  • dlt-daemon: update to 2.18.5
  • dnsmasq: upgrade 2.81 -> 2.82
  • doxygen: Upgrade 1.8.17 -> 1.8.20
  • drbd: Upgrade to 9.0.24-1
  • drbd-utils: Uphgrade to 9.13.1
  • emacs: Create a new recipe for emacs
  • evince: upgrade 3.36.5 -> 3.36.7
  • evolution-data-server: upgrade 3.36.3 -> 3.36.5
  • exiv2: upgrade 0.27.1 -> 0.27.3
  • fbida: require opengl in DISTRO_FEATURES
  • fbida: Upgrade to 2.14
  • file-roller: upgrade 3.36.2 -> 3.36.3
  • fio: upgrade to 3.21
  • firewalld: update to 0.8.3
  • flashrom: Fix build failure with glibc 2.32
  • fluentbit: Use -fcommon to compile
  • fmt: 6.2.0 -> 7.0.3
  • fping: update to 4.4
  • freeglut: Use -fcommon always
  • freeradius: fix the occasional verification failure
  • freerdp: Add missing libxkbcommon WL dependency
  • freerdp: Upgrade to 2.2.0
  • function2: 4.0.0 -> 4.1.0
  • fwknop: Fix build with gcc10
  • fwts: Upgrade to 20.07.00
  • gdm: upgrade 3.36.2 -> 3.36.3
  • gensio: Upgrade to 2.1.4
  • geoclue: upgrade 2.5.3 -> 2.5.6
  • gerbera: Disable PIE on rv64
  • gerbera: Upgrade to 1.6.0
  • gnome-calendar: initial add 3.36.2
  • gnome-control-center: upgrade 3.36.3 -> 3.36.4
  • gnome-desktop3: upgrade 3.36.3.1 -> 3.36.4
  • gnome-desktop3: upgrade 3.36.4 -> 3.36.5
  • gnome-disk-utility: re-add 3.36.3
  • gnome-help.bbclass: remove double FILES_PN-help entry
  • gnome-settings-daemon: Add introspection to UNKNOWN_CONFIGURE_WHITELIST
  • gnome-settings-daemon: Drop using autotools specific option
  • gnome-settings-daemon: Remove duplicate outdated SRC_URI hashes
  • gnome-settings-daemon: smartcard support is optional, and needs nss
  • gpm: Upgrade to latest master
  • gsoap: upgrade 2.8.103 -> 2.8.105
  • gtksourceview4: upgrade 4.6.0 -> 4.6.1
  • hiawatha: upgrade 10.10 -> 10.11
  • htop: Fix build with -fno-common
  • ifenslave: update to 2.11
  • ifplugd: Fix build with gcc10/-fno-common
  • iftop: Fix build with -fno-common
  • ifuse: update to 1.1.4
  • imagemagick: upgrade 7.0.9_13 -> 7.0.10_25
  • imsettings: Upgrade to 1.8.2
  • iozone3: upgrade 489 -> 490
  • ipc-run: upgrade 20180523.0 -> 20200505.0
  • ipmitool: Fix build with -fno-common
  • iscsi-initiator-utils: Upgrade to 2.1.2
  • iwd: Module load dir should be relative to root_dir
  • iwd: update to 1.8
  • jasper: upgrade 2.0.16 -> 2.0.19
  • jsoncpp: add PE do to dunfell reverts
  • jsonrpc: Fix build with libmicrohttpd 0.9.71
  • json-schema-validator: Add recipe
  • keepalived: update to 2.1.5
  • kernel-selftest: Disable vm tests for mips/arm
  • kernel-selftest: Tests in 5.8 depend on libhugetlbfs.h
  • kexecboot: Use -fcommon to compile
  • khronos-cts: add opengl to REQUIRED_DISTRO_FEATURES
  • klibc: Compile with -fcommon
  • kronosnet: update to 1.18
  • lcdproc: Fix compilation with GCC >= 10.x
  • lcov: fix lcov-native build
  • leptonica: update to 1.80.0
  • lftp: upgrade 4.9.1 -> 4.9.2
  • libbytesize: update to 2.4
  • libcamera: Fix License names to match SPDX convention
  • libcamera: fix packaging and installation
  • libcec: update to 6.0.2
  • libcgi-perl: upgrade 4.48 -> 4.50
  • libeigen: update SRC_URI to download from gitlab
  • libforms: Fix build with -fno-common
  • libgpiod: update v1.4.3 -> v1.4.4
  • libgweather: upgrade 3.36.0 -> 3.36.1
  • libidn: upgrade 1.35 -> 1.36
  • libimobiledevice: update to 1.3.0
  • libjcat: update to 0.1.3
  • libkcapi: update to 1.2.0
  • liblbxutil: Fix build with gcc10/-fno-common
  • libldb: upgrade 1.5.7 -> 1.5.8
  • libmbim: update to 1.24.2
  • libmediaart: update to 2.0_1.9.4
  • libmicrohttpd: upgrade 0.9.70 -> 0.9.71
  • libmpdclient: update to 2.19
  • libnet-dns-perl: upgrade 1.25 -> 1.26
  • libnma: upgrade 1.8.28 -> 1.8.30
  • libopusenc: add recipe 0.2.1
  • libpeas: disable tests when introspection is not enabled/available
  • libpeas: gobject-introspection is mandatory and cannot be configured
  • libpeas: this depends on gtk3+ add FEATURE CHECK
  • libpeas: update to 1.26.0
  • libplist: update to 2.2.0
  • libqmi: Delete --enable-more-warnings configure option
  • libqmi: update to 1.26.0
  • libteam: update to 1.31
  • libupnp: update to 1.14.0
  • liburing: add v0.7
  • libusbmuxd: update to 2.0.2
  • libvdpau: update to 1.4
  • libvncserver: update to 0.9.13
  • libwebsockets: update to 4.0.20
  • libyui-ncurses: Disable werror with clang
  • libyui-ncurses: update to 2.55.0
  • libyui: update to 3.10.0
  • libzip: update to 1.7.3
  • links: upgrade 2.20.2 -> 2.21
  • linuxptp: Fix cross build
  • linuxptp: upgrade 2.0 -> 3.0
  • live555: merge recipe with inc
  • live555: upgrade 20190828 -> 20200721
  • lprng: Fix build with -fno-common
  • lshw: Upgrade 2.18 -> 2.19
  • lsscsi: update to 0.31
  • lua: Security Advisory - lua - CVE-2020-15888
  • lvm2: allow for reproducible binary builds
  • makedumpfile: Fix build with -fno-common
  • mariadb: not use the bundled libpcre2
  • mariadb: package executables named with mariadb
  • mariadb: upgrade to 10.5.4
  • memtester: Fix build with -fno-common
  • mercurial: Upgrade 5.4 -> 5.5
  • meta-networking: dhcpcd: backport ALIGN compile error fix
  • meta-oe: opengl-es-cts install deqp test runners
  • mg: Upgrade to 20200723 tag
  • mimic: Upgrade to 1.3.0.1
  • minidlna: Fix build with -fno-common
  • minifi: Add recipe for c++ version
  • minifi-cpp: Fix build with lto/clang
  • minifi-cpp: Fix linking with libxml2
  • monit: Set monit files in temporary locations
  • monkey: Upgrade to 1.6.9
  • mosquitto: Upgrade 1.6.10 -> 1.6.11
  • mozjs: fix multilib conflict
  • mozjs: specify TMPDIR
  • mpc: update to 0.33
  • nano: update to 5.0
  • nano: upgrade 5.0 -> 5.1
  • ncftp: Fix build with -fno-common
  • ncmpc: update to 0.38
  • netperf: Fix build with -fno-common
  • netplan: Update to latest to fix build with -fno-common
  • nlohmann-json: upgrade 3.7.3 -> 3.9.0
  • nlohmann-json: upgrade 3.9.0 -> 3.9.1
  • nngpp: Add recipe
  • nodejs: Upgrade to 12.18.3
  • nostromo: upgrade 1.9.7 -> 1.9.9
  • nss: Avoid converting enum to void
  • nss: fix postinst script for nativesdk build
  • nvme-cli: update to 1.12
  • ocl-icd: Upgrade to latest
  • openal-soft: Update to 1.20.1
  • opencl-headers: Upgrade to v2020.06.16
  • opencl-icd-loader: Update beyond 2020.06.16
  • openconnect: update to 8.10
  • opencv: Upgrade to 4.4.0
  • opengl-es-cts: Use SECURITY_NOPIE_CFLAGS
  • openldap: upgrade 2.4.50 -> 2.4.51
  • openlldp: Update to latest master
  • openocd: Fix build with gcc10/-fno-common
  • opensaf: Fix build with -fno-common
  • opusfile: update to 0.12
  • ostree: update to 2020.5
  • owfs: Fix build with -fno-common
  • paho-mqtt-c: upgrade 1.3.2 -> 1.3.4
  • pegtl: Disable type-limits warning
  • pmdk: update to 1.9
  • poppler: upgrade 0.89.0 -> 0.90.1
  • poppler: upgrade 0.90.1 -> 20.08.0
  • prompt-toolkit: fix recipe
  • protobuf: upgrade 3.12.3 -> 3.13.0
  • purple-skypeweb: upgrade 1.5 -> 1.6
  • python3-aenum: Upgrade 2.2.3 -> 2.2.4
  • python3-argexec: Upgrade 1.0.2 -> 1.0.3
  • python3-asciitree: Add recipe
  • python3-asn1crypto: Upgrade 1.3.0 -> 1.4.0
  • python3-attrs: Upgrade 19.3.0 -> 20.1.0
  • python3-autobahn: Upgrade 20.6.2 -> 20.7.1
  • python3-backcall: add recipe
  • python3-bcrypt: Upgrade 3.1.7 -> 3.2.0
  • python3-bitarray: Upgrade 1.4.1 -> 1.5.2
  • python3-cantools: Upgrade 35.1.0 -> 35.3.0
  • python3-cbor2: Upgrade 5.1.1 -> 5.1.2
  • python3-cffi: Upgrade 1.14.0 -> 1.14.2
  • python3-click-repl: Add recipe
  • python3-click-spinner: Add recipe
  • python3-cmd2: Upgrade 1.1.0 -> 1.3.3
  • python3-colorlog: Upgrade 4.1.0 -> 5.2.1
  • python3-cryptography: fix two tests
  • python3-cryptography: Upgrade 2.8 -> 3.0
  • python3-custom-inherit: Add recipe
  • python3-diskcache: Upgrade 4.1.0 -> 5.0.1
  • python3-djangorestframework: Consolidate in a single file
  • python3-djangorestframework: Upgrade 3.9.0 -> 3.11.1
  • python3-dnspython: Upgrade 1.16.0 -> 2.0.0
  • python3-dominate: Upgrade 2.5.1 -> 2.5.2
  • python3-dynamic-dispatch: Upgrade 1.0.2 -> 1.0.3
  • python3-flask-login: Consolidate in a single file
  • python3-flask-login: Upgrade 0.4.1 -> 0.5.0
  • python3-gast: Upgrade 0.3.3 -> 0.4.0
  • python3-gmqtt: Upgarde 0.6.5 -> 0.6.7
  • python3-google-api-python-client: Upgrade 1.9.3 -> 1.10.0
  • python3-graphviz: Upgrade 0.14 -> 0.14.1
  • python3-greenstalk: add recipe for greenstalk python package.
  • python3-huey: Upgrade 2.2.0 -> 2.3.0
  • python3-humanize: Upgrade 2.5.0 -> 2.6.0
  • python3-hyperlink: Upgrade 19.0.0 -> 20.0.1
  • python3-inflection: Upgrade 0.5.0 -> 0.5.1
  • python3-ipython: add recipe
  • python3-ipython-genutils: add recipe
  • python3-isort: Upgrade 5.1.4 -> 5.4.2
  • python3-javaobj-py3: Upgrade 0.4.0.1 -> 0.4.1
  • python3-jdatetime: Added recipe
  • python3-jedi: add recipe
  • python3-langtable: Upgrade 0.0.51 -> 0.0.52
  • python3-lazy-object-proxy: Upgrade 1.5.0 -> 1.5.1
  • python3-lorem: Added recipe
  • python3-luma-core: Upgrade 1.14.0 -> 1.15.0
  • python3-lxml: Upgrade 4.5.1 -> 4.5.2
  • python3-matplotlib: Upgrade 3.2.2 -> 3.3.1
  • python3-matplotlib: Use lld for linking when using clang
  • python3-msm: Upgrade 0.8.7 -> 0.8.8
  • python3-networkx: Upgrade 2.4 -> 2.5
  • python3-nocasedict: Add recipe
  • python3-nocaselist: Add recipe
  • python3-openpyxl: Upgrade 3.0.3 -> 3.0.4
  • python3-pandas: Add workaround to fix build with clang
  • python3-pandas: Upgrade 1.0.5 -> 1.1.1
  • python3-paramiko: Added recipe
  • python3-parse: Upgrade 1.15.0 -> 1.16.0
  • python3-parso: add recipe
  • python3-parso: Upgrade 0.7.1 -> 0.8.0
  • python3-pickleshare: add recipe
  • python3-pid: Upgrade 3.0.3 -> 3.0.4
  • python3-pint: Upgrade 0.14 -> 0.15
  • python3-prompt-toolkit: Upgrade 3.0.5 -> 3.0.6
  • python3-pyalsaaudio: Consolidate in a single file
  • python3-pyalsaaudio: Upgrade 0.8.4 -> 0.9.0
  • python3-pybind11: install both python wheel and cmake build
  • python3-pybind11-json: Add recipe
  • python3-pychromecast: Upgrade 7.1.2 -> 7.2.1
  • python3-pydicti: Add recipe
  • python3-pymisp: Upgrade 2.4.128 -> 2.4.130
  • python3-pymongo: Upgrade 3.10.1 -> 3.11.0
  • python3-pynacl: Added recipe
  • python3-pyroute2: Upgrade 0.5.12 -> 0.5.13
  • python3-pytest-asyncio: Upgrade 0.12.0 -> 0.14.0
  • python3-pytest-timeout: Upgrade 1.4.1 -> 1.4.2
  • python3-python-vlc: Upgrade 3.0.10114 -> 3.0.11115
  • python3-pywbemtools: Add recipe
  • python3-pywbem: Upgrade 0.17.3 -> 1.0.2
  • python3-redis: Upgrade 2.10.6 -> 3.5.3
  • python3-regex: Upgrade 2020.6.8 -> 2020.7.14
  • python3-rsa: Upgrade 3.4.2 -> 4.6
  • python3-sentry-sdk: Upgrade 0.16.0 -> 0.16.5
  • python3-sqlalchemy: Upgrade 1.3.18 -> 1.3.19
  • python3-sympy: Upgrade 1.6.1 -> 1.6.2
  • python3-tabulate: Add recipe
  • python3-textparser: Added recipe
  • python3-tqdm: Upgrade 4.47.0 -> 4.48.2
  • python3-traitlets: add recipe
  • python3-typing-extensions: Upgrade 3.7.4.2 -> 3.7.4.3
  • python3-ujson: Upgrade 3.0.0 -> 3.1.0
  • python3-u-msgpack-python: Upgrade 2.6.0 -> 2.7.0
  • python3-urllib3: Upgrade 1.25.9 -> 1.25.10
  • python3-wheel: Upgrade 0.34.2 -> 0.35.1
  • python3-wtforms: Upgrade 2.3.1 -> 2.3.3
  • python3-xlsxwriter: Consolidate in a single file
  • python3-xlsxwriter: Upgrade 1.2.9 -> 1.3.3
  • python3-xxhash: Upgrade 1.4.4 -> 2.0.0
  • python3-yamlloader: Add recipe
  • python3-yarl: Upgrade 1.4.2 -> 1.5.1
  • quagga: Use -fcommon to compile
  • rasdaemon: update to 0.6.6 and fix SRC_URI broken link
  • rdist: fix parallel build
  • rdma-core: upgrade 28.0 -> 30.0
  • read-edid: Fix build with gcc-10+
  • redis: upgrade 6.0.5 -> 6.0.6
  • relayd: bump to latest revision
  • Revert "iwd: Module load dir should be relative to root_dir"
  • samba: upgrade 4.10.15 -> 4.10.17
  • sanlock: upgrade 3.8.1 -> 3.8.2
  • satyr: Upgrade to 0.31
  • sblim-sfcb: Fix build with -fno-common
  • sdbus-c++: Fix ptest packaging
  • sedutils: Fix build with clang11
  • ser2net: upgrade 4.1.8 -> 4.2.0
  • sharutils: Fix build with -fno-common
  • smstools3: Fix build with -fno-common
  • snort: Upgrade to 2.9.16.1
  • spdlog: Upgrade to 1.7.0
  • spitools: upgrade 0.8.4 -> 0.8.5
  • squid: upgrade 4.12 -> 4.13
  • tcsh: Fix build with -fno-common
  • terminus-font: update to 4.48
  • tftp-hpa: Fix build with -fno-common
  • tmux: update to 3.1b
  • tumbler: upgrade 0.2.8 -> 0.2.9
  • tvheadend: Update to latest tip
  • udisks2: upgrade 2.8.4+ -> 2.9.1
  • uhubctl: upgrade 2.1.0 -> 2.2.0
  • usbmuxd: update to 1.1.1
  • valijson: Move it to networking-layer under BBFILES_DYNAMIC
  • valijson: update to 0.3
  • vblade: Upgrade to version 24
  • vboxguestdrivers: Fix build with kernel 5.8
  • vboxguestdrivers: fix failed to compile with kernel 5.8.0
  • vboxguestdrivers: upgrade 6.1.6 -> 6.1.12
  • vulkan-cts: Update to 1.2.3.2
  • weechat: Upgrade to 2.9
  • wifi-test-suite: Update to latest tip
  • wireguard-module: Exlude from world builds
  • wireshark: upgrade 3.2.5 -> 3.2.6
  • x11vnc: Update to latest on master
  • xf86-video-ati: Fix link failure with gcc 10
  • xfce4-cpufreq-plugin: Fix build with -fno-common
  • xfce4-eyes-plugin: 4.5.0 -> 4.5.1
  • xfce4-sensors-plugin: Fix build with -fno-common
  • xfce4-timer-plugin: upgrade 1.7.0 -> 1.7.1
  • xfce4-whiskermenu-plugin: upgrade 2.4.5 -> 2.4.6
  • xfsprogs: Upgrade to 5.7.0
  • xfwm4: upgrade 4.14.2 -> 4.14.3
  • xfwm4: upgrade 4.14.3 -> 4.14.4
  • xfwm4: upgrade 4.14.4 -> 4.14.5
  • xmlrpc-c: fix Makefile macro error
  • xmlrpc-c: Upgrade 1.51.03 -> 1.54.02
  • xxhash: Upgrade 0.7.4 -> 0.8.0
  • zlog: upgrade 1.2.14 -> 1.2.15

Meta RISC-V

  • glibc: Update to the latest upstream submission
  • linux-yocto : Support kernel 5.8 for riscv32
  • openocd: Fix build with gcc10/-fno-common
  • README.md : Remove LSB related content that is deprecated

Meta Security

  • clamav: add INSTALL_CLAMAV_CVD flag to do_install
  • libseccomp: fix cross compile error for mips
  • libseccomp: update to 2.5.0
  • packagegroup-core-security: remove libseccomp for riscv
  • packagegroup-core-security: restore riscv64 for libssecomp
  • trousers: Several Security fixes

Meta Virtualization

  • ceph: fix do_compile error: 'sys_siglist' was not declared
  • docs: Add initial Xvisor doc
  • go-build: fix build with new go-binary bootstrapped toolchain
  • ipxe: fix build with gcc 10.1.0
  • k8s: fix 32bit ARM build
  • libvirt: fix install error without qemu
  • libvirt: specify location of dmidecode
  • runx: Fix linux kernel versions referenced in the recipe
  • xen, linux-raspberrypi4: remove linux-raspberrypi bbappends and patches
  • xen, raspberrypi: bugfix early boot messages: use earlycon=xenboot
  • xen, raspi4, linux-yocto-dev: Enable Xen on Raspberry Pi 4
  • xen: retire the Raspberry Pi sdcard class
  • xen, rpi4: use RPI_EXTRA_CONFIG and drop the rpi-config_git.bbappend
  • xen: upgrade to Xen 4.14 as default and advance the git recipe version
  • xen, xen-tools: move tools-specific EXTRA_OECONF to xen-tools.inc
  • xvisor: Add support for building AArch64
  • xvisor: Bump to a git release
  • xvisor-image-minimal: Initial commit of a Xvisor image

OpenEmbedded Core

  • acpica: upgrade 20200528 -> 20200717
  • allarch: Add missing allarch ttf-bitstream-vera
  • alsa-topology-conf: use ${datadir} in do_install()
  • alsa-ucm-conf: use ${datadir} in do_install()
  • asciidoc: upgrade 9.0.1 -> 9.0.2
  • bind: update to 9.11.22 ESV
  • binutils: Let crosssdk gold linker generate 4096 btyes long .interp section
  • binutils: Remove RISC-V PIE patch
  • binutils: Upgrade to 2.35 release
  • bison: upgrade 3.6.4 -> 3.7.1
  • bluez5: fix builds that require ell support
  • boost: update 1.73.0 -> 1.74.0
  • bootchart2: update 0.14.8 -> 0.14.9
  • build-compare: Drop recipe
  • buildcpio.py: Apply patch to fix build with -fno-common
  • buildgalculator: Patch to fix build with -fno-common
  • buildtools: Handle generic environment setup injection
  • cmake.bbclass: Rework compiler program variables for allarch
  • cmake: update 3.17.3 -> 3.18.1
  • cml1: Add the option to choose the .config root dir
  • cogl-1.0: correct X11 dependencies
  • conf/machine: set UBOOT_MACHINE for qemuarm and qemuarm64
  • conf/machine: set UBOOT_MACHINE for qemumips and qemumips64
  • connman-gnome/matchbox-desktop: Remove file:// globbing
  • cortex-m0plus.inc: Add tuning for cortex M0 plus
  • cryptodev: upgrade 1.10 -> 1.11
  • curl: Upgrade to 7.72.0
  • deb: Move deb manifest to its own subdir
  • deb: Move package manager to its own dir
  • deb: Move rootfs to its own dir
  • deb: Move sdk to its own dir
  • devtool: expand SRC_URI when guessing recipe update mode
  • dhcp: Use -fcommon compiler option
  • diffoscope: update to 156
  • distcc: Fix build with -fno-common
  • epiphany: upgrade 3.36.3 -> 3.36.4
  • ethtool: upgrade 5.7 -> 5.8
  • flex: Refresh patch
  • font-alias: upgrade 1.0.3 -> 1.0.4
  • fribidi: extend CVE_PRODUCT to include fribidi
  • gcc10: Don't default back to -fcommon
  • gcc: backport a fix for out-of-line atomics on aarch64
  • gcc-cross-canadian: Correct the regexp to delete versioned gcc binary
  • gcc-cross-canadian: Install gcc/g++ wrappers for musl
  • gcc: Fix mangled patch
  • gcc-runtime.inc: fix m32 compile fail with x86-64 compiler
  • gcc: Upgrade to 10.2.0
  • gcr: Fix patch Upstream-Status from v2 patch
  • gcr: make sure gcr-oids.h is generated
  • gettext: update 0.20.2 -> 0.21
  • ghostscript: fix CVE-2020-15900
  • git: update 2.28.0
  • glib-2.0: correct build with latest meson
  • glibc: Upgrade to 2.32 release
  • gnu-config: update to latest revision
  • gobject-introspection: disable scanner caching in install
  • go: Upgrade to 1.14.7
  • gpgme: fix multilib header conflict
  • gpgme: update 1.13.1 -> 1.14.0
  • grub: set CVE_PRODUCT to grub2
  • gtk+3: upgrade 3.24.21 -> 3.24.22
  • gtk-icon-cache.bbclass: add features_check
  • harfbuzz: convert to meson, enable gobject introspection
  • harfbuzz: upgrade 2.6.8 -> 2.7.1
  • image_types_wic: Add ASSUME_PROVIDED to WICVARS
  • inetutils: Fix build with -fno-common
  • ipk: Move ipk manifest to its own subdir
  • ipk: Move package manager to its own dir
  • ipk: Move rootfs to its own dir
  • ipk: Move sdk to its own dir
  • iproute2: upgrade 5.7.0 -> 5.8.0
  • json-c: update to 0.15
  • kbd: update 2.2.0 -> 2.3.0
  • kernel.bbclass: Configuration for environment with HOSTCXX
  • kernel.bbclass: Remove do_install[prefunc] no longer needed
  • kernel.bbclass: run do_symlink_kernsrc before do_patch
  • kernel: config cleanups for 5.8+
  • kernel-devicetree: Fix intermittent build failures caused by DTB builds
  • kernel-devsrc: 5.8 + gcc10 require gcc-plugins + libmpc-dev
  • kernel-devsrc: fix on target modules prepare for ARM
  • kernel-devsrc: fix x86 (32bit) on target module build
  • kernel-fitimage: build configuration for image tree when dtb is not present
  • kernel-yocto/5.8: add gmp-native dependency
  • kernel/yocto: allow dangling KERNEL_FEATURES
  • kernel-yocto: enhance configuration queue analysis capabilities
  • kernel-yocto: make # is not set matching more precise
  • kernel-yocto: set cwd before querying the meta data dir
  • kernel-yocto: split meta data gathering into patch and config phases
  • kexec-tools: Fix additional duplicate symbols on aarch64/x86_64 builds
  • kexec-tools: Fix build with -fno-common
  • kexec-tools: Fix build with -fno-common on ppc
  • layer.conf: fix adwaita-icon-theme signature change problem
  • libacpi: Fix build with -fno-common
  • libcap: update 2.36 -> 2.42
  • libc-headers: update to v5.8
  • libcheck: upgrade 0.15.0 -> 0.15.2
  • libexif: Enable native and nativesdk
  • libffi: fix multilib header conflict
  • libhandy: upstream has moved to gnome
  • libinput: Upgrade 1.15.6 -> 1.16.1
  • lib/oe/log_colorizer.py: add LogColorizerProxyProgressHandler
  • lib/oe/recipeutils.py: add support for BBFILES_DYNAMIC
  • lib/oe/reproducible.py: Fix git HEAD check
  • libomxil: Use -fcommon compiler option
  • lib/package_manager: Fix missing imports
  • libpipeline: upgrade 1.5.2 -> 1.5.3
  • libpsl: update 0.21.0 -> 0.21.1.
  • librsvg: Upgrade 2.40.20 -> 2.40.21
  • libubootenv: inherit uboot-config
  • libubootenv: uprev to v0.3
  • libunwind: Backport a fix for -fno-common option to compile
  • libwpe: update to 1.7.1
  • libx11: upgrade 1.6.9 -> 1.6.11
  • linux-firmware: upgrade 20200619 -> 20200817
  • linux-yocto/5.4: fix perf build with binutils 2.35
  • linux-yocto/5.4: perf cs-etm: Move definition of 'traceid_list' global variable from header file
  • linux-yocto/5.4: update to v5.4.60
  • linux-yocto/5.8: disable CONFIG_NFS_DISABLE_UDP_SUPPORT
  • linux-yocto/5.8: fix perf and virtio_scsi warnings
  • linux-yocto/5.8: selftests/bpf: Prevent runqslower from racing on building bpftool
  • linux-yocto/5.8: update to v5.8.3
  • linux-yocto: introduce 5.8 reference kernel
  • linux-yocto-rt/5.4: update to rt32
  • linux-yocto-rt/5.8: fix lttng-modules build
  • llvm: upgrade 9.0.1 -> 10.0.1
  • local.conf.sample: Document memory resident bitbake
  • localedef: Update to include floatn.h fix
  • logrotate: update 3.16.0 -> 3.17.0
  • ltp: make copyFrom scp command non-fatal
  • ltp: remove OOM tests from runtest/mm
  • lttng-modules: Disable on riscv64
  • lttng-modules: update to 2.12.2 (fixes v5.8+ builds)
  • lttng-tools: Do not build for riscv64
  • lttng-tools: upgrade 2.12.1 -> 2.12.2
  • maintainers: Update entries for Mark Hatle
  • make-mod-scripts: add HOSTCXX definitions and gmp-native dependency
  • man-pages: upgrade 5.07 -> 5.08
  • mc: upgrade 4.8.24 -> 4.8.25
  • mesa: update 20.1.2 -> 20.1.4
  • mesa: upgrade 20.1.4 -> 20.1.5
  • meson.bbclass: add a cups-config entry
  • meson: update 0.54.3 -> 0.55.0
  • meson: update 0.55.0 -> 0.55.1
  • meta-selftest: correct the virgl test for 5.8 kernels
  • minicom: Fix build when using -fno-common
  • multilib.conf: add u-boot to NON_MULTILIB_RECIPES
  • musl: Upgrade to latest release 1.2.1
  • nasm: update 2.14.02 -> 2.15.03
  • nativesdk-rpm: adjust RPM_CONFIGDIR paths dynamically
  • nativesdk-sdk-provides-dummy: Add /bin/sh
  • net-tools: fix upstream version check
  • nfs-utils: Drop StandardError=syslog from systemd unit
  • oeqa/manual/bsp-hw.json : remove shutdown_system test
  • oeqa/manual/bsp-hw.json : remove X_server_can_start_up_with_runlevel_5_boot test
  • oeqa: runtime_tests: Extra GPG debugging
  • oeqa/selftest: Apply patch to fix cpio build with -fno-common
  • oeqa/selftest/imagefeatures: Add testcase for fitImage
  • oeqa: write @OETestTag content into json test reports for each case
  • openssh: Drop StandardError=syslog from systemd unit
  • package.bbclass: Sort shlib2 output for hash equivalency
  • packagefeed-stability: Remove as obsolete
  • packagegroup-core-tools-profile: Disable lttng-modules for riscv64
  • package_manager: Move to package_manager/__init__.py
  • package_tar.bbclass: Sync to the other package classes
  • pango: update 1.44.7 -> 1.46.0
  • patch.py: Change to more strictly fuzz detection
  • pbzip2: extend for nativesdk
  • perf: backport a fix for confusing non-fatal error
  • perl: Add check for non-arch Storable.pm file
  • piglit: upgrade to latest revision
  • popt: upgrade to 1.18
  • populate_sdk_ext: Ensure buildtools doesn't corrupt OECORE_NATIVE_SYSROOT
  • pseudo: fix renaming to self
  • python3: Improve handling of python3 manifest generation
  • python3-manifest.json: Updates
  • python3-numpy: upgrade 1.19.0 -> 1.19.1
  • python3-setuptools: update to 49.6.0
  • qemu: bump default reference kernel to v5.8
  • qemu : fix CVE-2020-15863
  • qemu.inc: Use virtual/libgl instead of mesa
  • qemumips: Use 34Kf CPU emulation
  • qemu: Upgrade 5.0.0 -> 5.1.0
  • re2c: upgrade 2.0 -> 2.0.2
  • Revert "lib/oe/log_colorizer.py: add LogColorizerProxyProgressHandler"
  • rpm: Move manifest to its own subdir
  • rpm: Move package manager to its own dir
  • rpm: Move rootfs to its own dir
  • rpm: Move sdk to its own dir
  • rsync: update 3.2.1 -> 3.2.3
  • runqemu: Check gtk or sdl option is passed together with gl or gl-es options.
  • runqemu: fix permission check of /dev/vhost-net
  • runqemu: Show an error for conflicting graphics options
  • selftest/recipetool: Drop globbing SRC_URI test, no longer supported
  • selftest/tinfoil: Increase wait event timeout
  • sqlite3: upgrade 3.32.3 -> 3.33.0
  • strace: update to 5.8 (fix build against v5.8 uapi headers)
  • stress-ng:upgrade 0.11.15 -> 0.11.18
  • sudo:upgrade 1.9.1 -> 1.9.2
  • sysstat: upgrade 12.2.2 -> 12.4.0
  • systemd: Fix path to modules-load.d et al
  • systemd: Move musl patches to SRC_URI_MUSL
  • systemd: split systemd specific udev rules into its own package
  • systemd: Upgrade v245.6 -> v246.2
  • systemtap: update to 4.3 latest
  • sysvinit: update 2.96 -> 2.97
  • uninative: Handle PREMIRRORS generically
  • uninative: Upgrade to 2.9
  • util-linux: merge .inc into .bb
  • util-linux: upgrade 2.35.2 -> 2.36
  • vala: update 0.48.6 -> 0.48.7
  • vala: upgrade 0.48.7 -> 0.48.9
  • volatile-binds: Drop StandardOutput=syslog from systemd unit
  • webkitgtk: Upgrade to 2.28.4
  • weston: add missing packageconfigs
  • wic: Add 512 Byte alignment to --offset
  • wic: fix typo
  • wpebackend-fdo: update 1.6.1 -> 1.7.1
  • x264: upgrade to latest revision
  • xev: update 1.2.3 -> 1.2.4
  • xf86-video-intel: Fix build with -fno-common
  • xserver-xorg: Fix build with -fno-common/mips

Keep up to date with Foundries.io